Exercícios

1) Faça um algorítimo que receba as duas médias semestrais de um aluno, calcule a média anual, se a média anual for maior ou igual a cinco, exibir a mensagem “ALUNO APROVADO”, caso contrário exibir a mensagem “ALUNO REPROVADO”.

algoritimo “aprovado ou reprovado”

var

mediasemestre1, mediasemestre2, mediaanual : real

inicio

leia(mediasemestre1,mediasemestre2)

mediaanual<-(mediasemestre1+mediasemestre2)/2

se mediaanual >=5 entao

escreva (“ALUNO APROVADO”)

senao

escreva (“ALUNO REPROVADO”)

fimse

fimalgoritimo

2) Leia idade e a quantidade de dependentes de um funcionário e o salário atual, se a idade for > 49 ou o número de dependentes for > que 3 conceda 20% de aumento.

algoritimo “alegria de pobre”

var

idade, prole: inteiro

salarioatual, aumento: real

inicio

leia(idade, prole)

se idade > 49 ou prole > 3 entao

aumento<-(salarioatual*20)/100

salarioatual<-(salarioatual+aumento)

fimse

fimalgoritimo

3) Idem ao exercício 2, mas para receber 20% de aumento o funcionário deverá ter mais de 49 anos e ter mais de tres dependentes.
algoritimo “alegria de pobre2”

var

idade, prole: inteiro

salarioatual, aumento: real

inicio

leia(idade, prole)

se idade > 49 e prole > 3 entao

aumento<-(salarioatual*20)/100

salarioatual<-(salarioatual+aumento)

fimse

fimalgoritimo