Operações relacionais

 

 

Exemplos:

3=3 (retorna um valor verdadeiro)

3=8 (retorna um valor falso)

 

Operadores lógicos

var: lógico

A <- 6=3 (a variável A recebe o valor falso)

A <- 5>4 (a variável A recebe o valor verdadeiro)

 

tabela verdade: é o conjunto de todas as possibilidades combinatórias entre os valores de diversas variáveis lógicas, as quais se encontram em apenas duas situações, V ou F.

 

 

 

Exemplos:

 

  1. Se chover e relampejar, eu fico em casa.
  2. Se chover ou relampejar, eu fico em casa.

Estruturas de controle

Estrutura sequêncial : a estrutura sequêncial de um algorítimo corresponde ao fato de que o conjunto de instruções que compõem um algorítimo será executado em uma sequência linear para baixo, da esquerda para a direita, isto é, na mesma ordem em que foram escritas.

Estrutura de seleção: quando precisamos testar uma certa condição antes de excutar uma instrução usamos uma estrutura de seleção simples.

Sintaxe

Se <condição> então

.

.

.

instruções

Fimse

<condição> é uma expressão lógica que quando inspecionada pode gerar um resultado falso ou verdadeiro.

Se <condição> for verdadeiro, a instrução entre as cláusulas então e fim se será executada, caso contrário (<condição> for falsa) encerra-se a seleção (fimse), neste caso sem executar nenhuma instrução.

Exemplo:

Se media>=5 então

escreva(“Aluno Aprovado”)->instrução executada caso a condição media retorne verdadeiro

fimse

Seleção Composta

Quando tivermos situações em que duas alternativas dependem de uma mesma condição, sendo uma quando a condição retorna verdadeiro e outra quando a condição retorna falso, deve-se utilizar uma seleção composta.

Sintaxe

Se <condição> então

instruções

senao

instruções

fimse

Exemplo:

Se media >= 5 então

escreva (“Aluno aprovado”) -> instrução executada quando a condição media >=5 retornar verdadeiro

senão

escreva (“Aluno reprovado”) -> instrução executada caso falso

fim se